The ORM Foundation

Get the facts!

Tutorial #5

Last post 05-13-2013 13:57 by chrobiso. 6 replies.
Page 1 of 1 (7 items)
Sort Posts: Previous Next
  • 05-08-2013 10:59

    Tutorial #5

     Firstly, let me say that the more that I play with NORMA, the more fascinated I become.  The tutorials are clearly written, well paced, and cover an impressive range of the tool's features.

    I have come across a very few situations where what I experience - using VS 2010 with Release 17 - doesn't exactly match the behavior described in the tutorials. I would like to know whether my results are typical or if I am missing something.  It may simply be a version issue since the tutorials were written before the VS 2010 edition was developed.

    On page 22 of the Lab5 tutorial it states that clicking a predicate in the Verbalizer window will select that predicate in the Diagram Spy.  I don't experience this behavior - clicking the hyperlink does nothing.  I can of course still access the predicate's Properties by locating it manually in one of the diagrams, I just can't use the Verbalizer as a shortcut to locating the predicate.

    This is far and away the most significant discrepancy between the tutorials and my experience.  The rest are trivial things that seem to suggest that a tutorial's screen shots were based on a more robust model than the one that is being built. For example, on page 23 of the same tutorial, the Gender entity appears shadowed even though this is the first reference of that entity in this lab.

    All in all, impressive support for an impressive and FREE tool: thank you, Thank You, THANK YOU!


  • 05-08-2013 21:55 In reply to

    Re: Tutorial #5


    We're glad you're enjoying the tool and tutorials. There may be occasional things in the tutorials that are out of date, but the vast majority should be current. You can see detailed changes (grouped by category as well as by change date) in the Readme.htm file that installs with NORMA, so any discrepancies should be addressed there.

    A fairly recent change allows the shadows to be turned off, which can be useful for screen shots in mature models.

    As for the main question, there are four things I can think of that could cause this behavior. I'm assuming you can manually 'Select in Diagram Spy' from the document window and Model Browser tool window:

    1. The third button down on the Verbalization Browser toolbar has been toggled to hyperlink to the document window instead of the Diagram Spy window. If this has been toggled, then you often won't notice a change when a hyperlink is clicked.
    2. You're clicking in an area that isn't hyperlinked (unlikely, the 'hand' icon and a very subtle background change will indicate what is hyperlinked).
    3. You're clicking on a predicate reading that does not have a shape, such as the reference scheme fact type 'A has/is of A_id' generated when you set the reference mode of A to '.id'. The hyperlink jump in this case will take you to the fact type in the model browser.
    4. The hyperlinks have been turned off in the Tools/Options dialog. This is available so that hyperlinks are not pasted into Word (etc.) if you're copying in verbalizations. Look under the ORM Designer tab in the Tools/Options dialog and open the 'Alternate Verbalization Text' dropdown. Expanding Core ORM Verbalization/Browser Settings and choosing the Default (No Hyperlinks) setting will do this.

    Let me know if any of the this helps.


  • 05-09-2013 14:05 In reply to

    Re: Tutorial #5

    Matt -

    Thanks for the reply; I read the Readme.htm file and found nothing beyond your suggestions, which I address below:

    1.) Button was set to Diagram Spy, but toggling it made no discernable difference - both settings fail to highlight the predicate in either the Diagram Spy or the Model browser.

    2.) I get the hand icon but don't notice any subtle background change when mousing over.  (When I click on a link it gets a dashed border.)  I have tried selecting the lab's Person entity type and have clicked each of its verbalization predicate links without result.

    3.) see 2.) above.

    4.) The setting was configured as Default; changing it to Default, No Hyperlinks (English (United States)) eliminates the hand icon and hyperlink.

    Still puzzled.

    - Chris 



  • 05-10-2013 0:27 In reply to

    Re: Tutorial #5

    Hi Chris,

    The background is very subtle (the a:hover style uses the infobackground backcolor, which is very light on most systems). It is easiest to see when hovering over a red model error description in the verbalization window.

    I'm just not seeing this. I've tried VS2010 on two different platforms (XP32+IE8 and Win764+IE10) to see if the browser was the issue.

    This is acting like you have some security settings and/or virus checker that is rejecting hyperlinks it doesn't recognize, which would definitely affect the browser control. The jumps are handled through a standard WebBrowser.Navigating event with a check for the 'elementid' scheme in the URL.Scheme property. If you view the source, you'll find that all of the hrefs look like href="elementid:SOMEGUID". The Browser_OnNavigating event handler always cancels the event for the elementid scheme, so you shouldn't be getting to the dashed-border-around-the-hyperlink stage if this handler is running (regardless of whether or not the jump succeeds). So, it doesn't sound like it is even running the jump code on your machine, which is very odd.

    So, maybe you can give a little more data on your system?

    Has anyone else see this behavior?


  • 05-10-2013 18:00 In reply to

    Re: Tutorial #5

     Matt -

    I'm on Win7 32bit with IE8. I'm at a government site, so my security protocol is pretty strict (and often inflexible), being particularly paranoid about malicious hyperlinks.  I'll pass this thread by the system engineers and see if it tickles anything with them.  I would also be happy to check any configuration settings that you think may be affecting this although I generally don't personalize VS or IE much at all from our defaults.  I just went through the advanced settings in IE and nothing jumped out at me as pertaining to hyperlink rejection.

    View source reveals just what you describe for the hyperlinks, but you are over my head with the event handling / schemes.  I am seeing the background now - a pale yellow that was definitely not there yesterday - and the dashed border is now gone. I swear I haven't changed anything that could affect that, but is that my credibility that I just heard crashing?... ;-)

    Unfortunately, although there are other VS developers here, I am the only person using NORMA at my facility; are there any native VS components that would expose similar behavior?


     Thanks again for your time,

  • 05-11-2013 8:09 In reply to

    Re: Tutorial #5

    I am seeing the background now - a pale yellow that was definitely not there yesterday
    Are you on the same screen? Fine shades disappear if the screen brightness & contrast aren't set correctly, perhaps that's why you didn't see them?
  • 05-13-2013 13:57 In reply to

    Re: Tutorial #5

    Clifford -

    Interesting observation.  At the office, running a monitor through a docking station, I don't see the background effect, and I do see the dashed border.  At home running off the vga port I see the background effect and don't see the dashed border (but when I started this thread, at home, I am sure that I didn't see the background effect and did see the border).  Dropping the brightness and contrast (both were 100%) at work does get me the background, and the dashed border remains.  I will see tonight what similar fiddling will do at home.

    - Chris 



Page 1 of 1 (7 items)
© 2008-2014 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service