in

The ORM Foundation

Get the facts!

Syntax highlighting no longer working in ORM fact editor

Last post 04-21-2014 22:45 by koneill. 2 replies.
Page 1 of 1 (3 items)
Sort Posts: Previous Next
  • 04-18-2014 2:19

    • koneill
    • Top 25 Contributor
      Male
    • Joined on 02-17-2012
    • The Netherlands
    • Posts 29

    Syntax highlighting no longer working in ORM fact editor

     Help! Smile. I've lost the syntax highlighting in the ORM fact editor: any text I type in is black. Does anyone know how to restore the syntax highlighting? I've already tried quite a few things like uninstalling NORMA and VS2012. Any help would be greatly appreciated.

     Regards,

    Karl

  • 04-18-2014 15:34 In reply to

    Re: Syntax highlighting no longer working in ORM fact editor

    Hi Karl,

    Getting editor colors to work got significantly harder for the VS2012 release. It sounds like something is off in your color settings, but I don't verify the colors are properly registered because it is already flagged in the registry as being checked for this NORMA version, meaning that it won't recheck until you install a newer version. The issue is discussed in this MSDN thread.

    The first thing to try is to:

    1. Shut down Visual Studio.
    2. Using the regedit utility, delete the FactEditorColorsCheckedForRevision value from the HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0\ORM Solutions\Natural ORM Architect key in the registry.
    3. Restart VS and NORMA
    If that doesn't do it, you'll need to blow away the HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\12.0\FontAndColors\Cache (or at a minimum the {A27B4E24-A735-4d1d-B8E7-9716E1E3D8E0} key inside Cache if you don't want to force a reload of colors for all editors). This will up your editor load time in VS as each editor resets its colors, and you'll lose any customizations, but it should force your colors to reset.
     
    -Matt 
     
    Let use know if either of these changes fix the problem.
     
    -Matt 

  • 04-21-2014 22:45 In reply to

    • koneill
    • Top 25 Contributor
      Male
    • Joined on 02-17-2012
    • The Netherlands
    • Posts 29

    Re: Syntax highlighting no longer working in ORM fact editor

     Matt,

     The first option works like a charm! Syntax highlighting is working again. Thanks for the help.

     Regards,

    Karl

Page 1 of 1 (3 items)
© 2008-2014 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service