in

The ORM Foundation

Get the facts!

Problems installing NORMA in Visual Studio Community 2015

Last post Tue, Oct 24 2017 14:17 by Ken Evans. 4 replies.
Page 1 of 1 (5 items)
Sort Posts: Previous Next
  • Tue, Feb 2 2016 14:15

    Problems installing NORMA in Visual Studio Community 2015

     Hi

    I have installed Visual Studio Community 2015 on my PC,
    and I have downloaded NORMA for Visual Studio 2015.

    When trying to install NORMA, I am presented with this dialogue box:

     

    Un sourceforge.net I can find only PLiX for VS 2008 only, and that refuses to install on VS Community 2015.

    So I'm stuck.

    As the frontpage of ormfoundation.org states that, "1 October 2015: New release of NORMA
    New version for Visual Studio 2015 is now available for download. This version has been tested on Windows 10. 
    More good news: NORMA runs in the FREE Editions of Visual Studio 2013 & 2015  " 

    - I guess, that I must be doing something wrong - and as have had absolutely no experience with VS ever, that I quite likely.

    Any advise on this matter will be msot appreciated.

    Best regards
    Kim 


  • Thu, Feb 4 2016 7:46 In reply to

    • jacobvos
    • Top 25 Contributor
      Male
    • Joined on Mon, Jan 21 2013
    • The Netherlands
    • Posts 39

    Re: Problems installing NORMA in Visual Studio Community 2015

    Hello,

    Did you run 'PLiX for Visual Studio.msi' that comes with the NORMA for VS2015 download?

    Regards,
    Jacob

  • Thu, Feb 4 2016 8:35 In reply to

    Re: Problems installing NORMA in Visual Studio Community 2015

     Hello Jacob

    Ken gave some hints, and eventually I succeeded to install and run.

    Thanks.

    Best regards

    Kim 

  • Tue, Oct 24 2017 10:39 In reply to

    Re: Problems installing NORMA in Visual Studio Community 2015

    Hello Kim,

    I am facing some issues to install the NORMA plugin under VS 2015.

    Do you have a pointer/reference about the suggestion you received from Ken?

    In my case, after the installation, the list of plugins appear to be corrupted: when I attempt to create a new file, the VS interface does not show any plugin template and I cannot create any.

    Any suggestion is much appreciated.

    Thank you in advance,

    Daniele 

  • Tue, Oct 24 2017 14:17 In reply to

    • Ken Evans
    • Top 10 Contributor
      Male
    • Joined on Sun, Nov 18 2007
    • Stickford, UK
    • Posts 748

    Re: Problems installing NORMA in Visual Studio Community 2015

     Hi Daniele,

    Please give more details on your problem.

    Which operating system are you using? 

    Did NORMA install without errors?

    PLiX should have been installed as part of the NORMA installation.
    You can check this by looking at the Programs list - PLiX is after NORMA in the list.

    Where are you seeing a "list of plugins"?
    Why are you looking at this list?

    If NORMA installed correctly then the procedure for starting a new object-role model instance is as follows:
    1: Start Visual Studio

    2: File>New>File - then choose "Object-Role Modeling File" from the list.

    Ken 

     

     

     

       

Page 1 of 1 (5 items)
© 2008-2018 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service