in

The ORM Foundation

Get the facts!

NORMA within visual studion 2015

Last post Thu, Feb 1 2018 20:59 by Ken Evans. 1 replies.
Page 1 of 1 (2 items)
Sort Posts: Previous Next
  • Thu, Feb 1 2018 18:38

    NORMA within visual studion 2015

     HI all, first time trying to do NORMA within VS 2015 community edition UPdate 3

     I got VS going ( I think!) and ran the NORMA bat ( several different ways)

    opened up VS and did see ORMModel  in the file list.

    But no graphics when I dbl click. , but just the XML as below

    <?xml version="1.0" encoding="utf-8"?>
    <?new?>
    <ormRoot:ORM2 xmlns:orm="http://schemas.neumont.edu/ORM/2006-04/ORMCore" xmlns:ormDiagram="http://schemas.neumont.edu/ORM/2006-04/ORMDiagram" xmlns:ormRoot="http://schemas.neumont.edu/ORM/2006-04/ORMRoot">
        <orm:ORMModel id="modelId" Name="$fileinputname$"/>
        <ormDiagram:ORMDiagram id="diagramId" IsCompleteView="false" Name="$fileinputname$" BaseFontName="Tahoma" BaseFontSize="0.0972222238779068">
            <ormDiagram:Subject ref="modelId"/>
        </ormDiagram:ORMDiagram>
    </ormRoot:ORM2>
     

     

    CLicking on the XSLT icon also shows the XML

    <?xml version="1.0" encoding="utf-8"?>
    <xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
        xmlns:msxsl="urn:schemas-microsoft-com:xslt" exclude-result-prefixes="msxsl"
    >
        <xsl:output method="xml" indent="yes"/>

        <xsl:template match="@* | node()">
            <xsl:copy>
                <xsl:apply-templates select="@* | node()"/>
            </xsl:copy>
        </xsl:template>
    </xsl:stylesheet>
     

    any thoughts would be helpful  ( spent a lot of time getting the 2015 version community edition)

    regards rob rucker ( lecturer in the IT dept. ASU polytechnic campus) 

    robert.rucker@asu.edu

    480 332 9798 

  • Thu, Feb 1 2018 20:59 In reply to

    • Ken Evans
    • Top 10 Contributor
      Male
    • Joined on Sun, Nov 18 2007
    • Stickford, UK
    • Posts 751

    Re: NORMA within visual studion 2015

    Hi Rob,

    I have recently bought a new PC and installed VS2015 update 3 and the version of Norma that can be downloaded from the Library on this website -so it does work!

    What I suggest that you do is to uninstall NORMA and PLiX from "Windows- Add or Remove programs"
    Then run the PliX msi followed by the NORMA msi that you will see when you unzip the NORMA for VS2015 download. (They are the two top items - called "Windows Installer Packages"

     If NORMA installed correctly, then to start NORMA you proceed as follows in Visual Studio 2015 Community Edition.

    Open VS2015
    Click File>New>File
    Scroll down the list
    Double click on "Object-Role Modeling File" and NORMA will start.

    Let me know how it goes.

    Ken 

     

     

     

     

     


Page 1 of 1 (2 items)
© 2008-2018 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service