in

The ORM Foundation

Get the facts!

ORM plugin doesn't work with VS 2008?

Last post 08-07-2008 17:08 by akoval. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 08-07-2008 10:38

    • akoval
    • Top 150 Contributor
    • Joined on 08-07-2008
    • Posts 3

    ORM plugin doesn't work with VS 2008?

    Hi,

     

    I have downloaded the plugin for Visual Studio from

    http://sourceforge.net/project/showfiles.php?group_id=158881

    While running the setup, the installer tried to find VS 2005. I use VS 2008, how can I use the ORM extension for VS 2008?

     

    thanks,

     

    Alex Koval 

    Filed under:
  • 08-07-2008 11:01 In reply to

    Re: ORM plugin doesn't work with VS 2008?

    Hello Alex,

    Did you notice that there are seperate nORMa install packages for VS 2005 and VS 2008?  Given that the CTP date is in the title, it's easy to grab the wrong package.  If that's not the problem, let me know.

    BTW, you can also get the tool CTP packages from the Library section here on OF.  As long as you're signed in, you can download what you need.  http://www.ormfoundation.org/files/folders/norma/entry1046.aspx   It says May release, but the release date is June 9th - anyway, it's the most current.  In the Libray section, click Most Recent, and it's a few entry down on the page.  If you click the title link, you'll see the release notes.

    Make sure to look at the readme install notes that come with the package.  VS 2008 package install is a bit easier than  that for VS 2005.  Functionally, there's little difference in the nORMa tool; but VS 2008 version supports LINQ name generation.

    Hope it helps,

    BRN..

  • 08-07-2008 12:04 In reply to

    • akoval
    • Top 150 Contributor
    • Joined on 08-07-2008
    • Posts 3

    Re: ORM plugin doesn't work with VS 2008?

     Hello Brian,

     

    Thank you a lot for the information. I see the correct installation. Now I have a different problem. When running the Setup.exe I am getting the output below. Could you please advise what is the problem?

    many thanks, 

    Alex 

    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 

    Neumont Object-Role Modeling Architect for Visual Studio 2008 Installation
    Installing current PLiX version
    New PLiX version failed to install

     >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

  • 08-07-2008 14:47 In reply to

    Re: ORM plugin doesn't work with VS 2008?

     Hi Alex,

    Still a bit of frustration with the install - too bad; I'm sure you'd like to get going with using the tool.  Odds are the install issue is a minor one, and I'll offer a few ideas.  Whether these workout for you or not, do send Matt Curland an email (in case he doesn't see your post).  He's the guy I ask when I have issues with the tool.  He's the chief architect for the tool; and is interested in finding out about install problems. 

    PLiX is an abstraction layer component required by the tool. While a normal install of the nORMa CTP should check for, and install, the the latest version of PLiX, you can install it separately.  I'd suggest using Windows Control Panel to get to the uninstall function.  Find and uninstall any "Neumont" applications - specifically the tool and PLiX.

    You can try running setup again, and it may well work this time.  Or, you can install PLiX (it's in the package you downloaded), separately.  If you open and extract all the files in the package you downloaded (a good idea anyway), you'll see a separate install for PLiX, and another for the tool. Install PLiX, then the tool.

    The good news is that the uninstalling and reinstalling are pretty quick - nothing like reinstalling VS!

    If that doesn't work, post again.  Good luck,

    BRN..

    Filed under: , ,
  • 08-07-2008 15:39 In reply to

    Re: ORM plugin doesn't work with VS 2008?

    Things to check (in order):

    1. Make sure you're running setup.bat as an administrator or from an administrator command prompt.
    2. Run 'appwiz.cpl' (the Add/Remove Programs control panel app) and make sure previous Neumont* programs are uninstalled. (If you haven't installed NORMA before, then you shouldn't have any entries).
    3. Run the two .msi files by hand (PLiX first, then NORMA)
    4. Modify the msiexec.exe commands in the batch file to add logging. For example, change start /w msiexec.exe /i "%~dp0PLiX for Visual Studio.msi" /q to start /w msiexec.exe /i "%~dp0PLiX for Visual Studio.msi" /q /l* "%~dp0Install.log" You can see more explicit logging options by running msiexec /?. In the batch file, we use /x for uninstall and /i for install. You'll need to have the zip expanded to write the log file to the same directory.

    I'm hoping 1 will fix the problem. If you get to 4 and have a failure, e-mail me the log (it won't be very exciting forum material).

    -Matt

  • 08-07-2008 17:08 In reply to

    • akoval
    • Top 150 Contributor
    • Joined on 08-07-2008
    • Posts 3

    Re: ORM plugin doesn't work with VS 2008?

    Hello Matt and Brian,

     

    I have successfully installed the ORM extension for VS 2008. Your advise to install separate msi has helped.

    Thank you very much!

     

    Alex Koval 

Page 1 of 1 (6 items)
© 2008-2014 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service