in

The ORM Foundation

Get the facts!

Edit post link does not work

Last post 01-26-2009 23:45 by Andy Reiser. 3 replies.
Page 1 of 1 (4 items)
Sort Posts: Previous Next
  • 01-26-2009 0:51

    • Andy Reiser
    • Top 50 Contributor
      Male
    • Joined on 01-24-2009
    • Sunshine Coast, Queensland, Australia
    • Posts 14

    Edit post link does not work

    The Edit link for posts does not seem to work. Every time I click post on the edit page for a post that I had previously written, the changes that I made do not stick. Check out the opening post on this thread for an example. I tried to clean that up many times with no luck.

    I think your problem is the fact that you are using an ASP.NET-based forum backend. As great as ASP.NET is, it seems incapable of handling forum requirements. I always seem to have these problems on ASP.NET forums.

     I recommend swapping to a php forum software. They are faster and never have these problems. PHP is not my favourite language, but it is easily the superior language for forum software.

  • 01-26-2009 5:10 In reply to

    Re: Edit post link does not work

    Hi Andy,

    Andy Reiser:
    The Edit link for posts does not seem to work.

    Thanks for your comment and for your suggested solution.
    However, that fact is that the "Edit feature does work".
    When you make an edit to a post, the forum application requires that you also make an entry in the "reasons for edit window" at the bottom of the post. (see diagram below)

    Another point to note is that all posts are sent back to the backend database before being re-displayed in your browser.
    Depending on the load on the server at the time, this sometimes causes a delay of a minute or two.

    Thus "the problem" that you have experienced is related to the Forum application design - which is not related to ASP.NET. 

    Hope this helps
    Ken

     


    Filed under:
  • 01-26-2009 9:45 In reply to

    Re: Edit post link does not work

    Hi Andy,

    Thanks again for your comment which relates to website usability.
    As a solution to this problem, I have updated the website code to display a message agaist the "Edit Notes" header.

    Please let me know if you think that this message "does the trick".
    In other words, if that comment had been there would you have noticed it?

    Ken

    Filed under:
  • 01-26-2009 23:45 In reply to

    • Andy Reiser
    • Top 50 Contributor
      Male
    • Joined on 01-24-2009
    • Sunshine Coast, Queensland, Australia
    • Posts 14

    Re: Edit post link does not work

     Hi Ken,

    Thanks for addressing that for me. Looks like I jumped the gun a bit. I think a big error message in red font would definitely do the trick - that is, when a user clicks post  without filling in that other textbox.

     It's a great forum. ORM deserves a forum, and I'm glad that one came into being.

    Cheers.

Page 1 of 1 (4 items)
© 2008-2014 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service