in

The ORM Foundation

Get the facts!

NORMA VS2010 ValueRange

Last post 09-13-2011 16:10 by haakon. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • 09-09-2011 5:04

    NORMA VS2010 ValueRange

    Im Trying to add a ValueRange on a DataType: Text: Variable Length. I Type like it says in Lab 3 "Mr, Mrs, Miss, Ms" and then i press enter: it now says: "{'Mr, Mrs, Miss, Ms'}" instead of "{'Mr', 'Mrs', 'Miss', 'Ms''}". Is there a problem what i am doing or is this a bug? Because when i genereate a SQL Script it also do the wrong: "CHECK (persontitle IN (N'Mr, Mrs, Miss, Ms'))" instead of "CHECK (persontitle IN (N'Mr', N'Mrs', N'Miss', N'Ms')),"
  • 09-09-2011 11:42 In reply to

    Re: NORMA VS2010 ValueRange

    Hello,

    You need to enter the text without the surrounding quotes. Type Mr,Mrs,Miss,Ms into the ValueRange field and you'll get the correct result. It should list back as {'Mr', 'Mrs', 'Miss', 'Ms'} when you press enter.

    -Matt

  • 09-11-2011 17:36 In reply to

    • haakon
    • Top 200 Contributor
    • Joined on 09-11-2011
    • Posts 2

    Re: NORMA VS2010 ValueRange

    I have the exact same problem, I type Mr,Mrs,Miss,Ms and end up with {'Mr,Mrs,Miss,Ms'}. I did not include any quotes. If I do include apostrophes around each element ('Mr', 'Mrs', 'Miss', 'Ms'), I get {'Mr'', ''Mrs'', ''Miss'', ''Ms'}. Entering {'Mr', 'Mrs', 'Miss', 'Ms'} also gives {'Mr'', ''Mrs'', ''Miss'', ''Ms'}. So there seems to be a bug in the parsing code! I also use VS2010, NORMA 4 July version. Good tutorials anyway!
  • 09-12-2011 3:29 In reply to

    Re: NORMA VS2010 ValueRange

    That is exactly what i mean. Ok, then it is not only me who have this problem. I Agree nice tutorial.
  • 09-13-2011 12:26 In reply to

    Re: NORMA VS2010 ValueRange

    Answer

    Hi All,

    I'll take another stab at this:

    1. Start/Run (or WindowsKey+R) intl.cpl (or find 'Regional and Language Options' on the control panel)
    2. Click the Customize button (XP) or 'Additional Settings' (Windows 7)
    3. Look at the List Separator value
    4. Use this as your list separator (probably a ;) instead of a ,

    NORMA parses and displays the value lists using the locale settings on your machine. The behavior you're describing implies that the list separator is not a comma, so it is treated as a normal character.

    -Matt

  • 09-13-2011 16:10 In reply to

    • haakon
    • Top 200 Contributor
    • Joined on 09-11-2011
    • Posts 2

    Re: NORMA VS2010 ValueRange

    Yup, thanks for the help, that was it! It works when using the ; instead of , . Guess that's how we separate stuff here in Norway! Interesting case of localization.. We use the comma , as a decimal point, so I guess that's why that character can't be used for list separation.
Page 1 of 1 (6 items)
© 2008-2014 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service