in

The ORM Foundation

Get the facts!

Failed install on Windows7, VS2008

Last post 10-24-2009 9:58 by Ken Evans. 6 replies.
Page 1 of 1 (7 items)
Sort Posts: Previous Next
  • 08-11-2009 13:50

    Failed install on Windows7, VS2008

    I have been running NORMA on Windows7, Visual Studio 2008, using the Windows7 release candidate.  Worked fine with the March release of NORMA.

    Yesterday I wiped my disk and installed Windows7 Released (RTM), installed VS2008, and tried to install NORMA, using the 2209_06CTP. The install script somehow thinks I'm installing into VS 2005! (see attached graphic)

    Any clues?


    Jim Ludden
    Filed under: ,
  • 08-11-2009 15:29 In reply to

    Re: Failed install on Windows7, VS2008

    Jim,

    The error message is wrong, but the rest of the setup package is VS2008. I'll look into conditionally compiling a 2008 string into setup; I just missed it when I conditionally compiled the rest of setup for the two targets.

    The more urgent question is why setup thinks that VS2008 is not installed. Setup checks for the following registry keys.

    • ProductDir value in HKLM\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VS (usually C:\Program Files\Microsoft Visual Studio 9.0\)
    • EnvironmentPath in HKLM\SOFTWARE\Microsoft\VisualStudio\9.0\Setup\VS (usually C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe)
    • UserFolder value in HKLM\SOFTWARE\Microsoft\VisualStudio\9.0\VSTemplate\Item (usually C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\ItemTemplates)

    What language packages did you install with VS?

    -Matt

  • 08-12-2009 17:31 In reply to

    Re: Failed install on Windows7, VS2008

    Operator error (once again) :(

    I find that after I upgrade to VS2008 SP1 the installation completes nicely.  However, I'm not certain whether this is specific to Windows 7.

    -Jim

    Jim Ludden
  • 08-12-2009 17:34 In reply to

    Re: Failed install on Windows7, VS2008

    I thought that I requested only C#, but only C++ is installed.

    Jim Ludden
  • 08-12-2009 18:18 In reply to

    Re: Failed install on Windows7, VS2008

    Actually, C++ only might cause the problem. I believe C++ uses a different templating mechanism and does not add the template item keys mentioned earlier.

    -Matt

  • 10-23-2009 22:26 In reply to

    Re: Failed install on Windows7, VS2008

     I've downloaded Visual Studio 2010 Beta 2 on my home machine and I'd like to load NORMA.

     I'm also getting the error message that it is looking for VS 2005.

     (I have Norma loaded at work in VS 2008 and it's working fine.)

    Will we be able to load NORMA in VS 2010 any time soon?

    Alex Bleier

  • 10-24-2009 9:58 In reply to

    Re: Failed install on Windows7, VS2008

    Jim,

    I'm planning a systems upgrade. 

    So please will you let me know more about your experience of running NORMA on Win 7.
    Are you running NORMA in Win 7 native mode or in the XP mode?

    Is your machine 32 bit or 64 bit?

    Thanks

    Ken 

    Filed under:
Page 1 of 1 (7 items)
© 2008-2014 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service