in

The ORM Foundation

Get the facts!

Why would NORMA not absorb a subtype?

Last post Wed, Mar 9 2011 4:39 by Ken Evans. 5 replies.
Page 1 of 1 (6 items)
Sort Posts: Previous Next
  • Mon, Mar 7 2011 10:13

    Why would NORMA not absorb a subtype?

    I've got a subtype for an objectified fact that I expected would be absorbed, but it's not.

    The AbsorptionChoice  property is set to "Absorbed".

     I'm new to ORM, so I'd guess there's something I've done wrong, but after looking at 11.3 in the BBB I can't figure it out.

     

    Any tips on what to check?

    Thank you,

    Charles Wilt


     

  • Mon, Mar 7 2011 13:51 In reply to

    Re: Why would NORMA not absorb a subtype?

    Hi Charles,

    Is there any way you could show the part of your model that is not behaving according to your expectations?

    You can use the new cross-model drag features to pull out the relevant fact types and object types into a separate model (the first time dropping into a new model, say yes to turn on the extensions, then repeat the drag/drop), dragging additional model elements from the original model until you get the unexpected results from the tool.

    -Matt

  • Mon, Mar 7 2011 14:16 In reply to

    Re: Why would NORMA not absorb a subtype?

    Matt,

    Should I post the resulting .ORM file?

    It's actually a pretty small model at present, I could probably post the original.

    Or do a screen cap, or copy & paste from the fact editor/verbalizer.

     

    Charles

  • Mon, Mar 7 2011 14:51 In reply to

    Re: Why would NORMA not absorb a subtype?

    Charles,

    Attaching the ORM file (on the options tab) certainly makes it easier to look evaluate, especially if it is still small. Not everyone is comfortable posting their original models because they may be proprietary, but if you're not worried about that please go ahead.

    -Matt

  • Mon, Mar 7 2011 17:05 In reply to

    Re: Why would NORMA not absorb a subtype?

    Well don't think it'd be proprietary....too basic for that....but I am afraid of what all I might have done wrong. :)

    How do you post models or images?

    Charles
  • Wed, Mar 9 2011 4:39 In reply to

    • Ken Evans
    • Top 10 Contributor
      Male
    • Joined on Sun, Nov 18 2007
    • Stickford, UK
    • Posts 799

    Re: Why would NORMA not absorb a subtype?

    charles.wilt:

    How do you post models or images?

    Hi Charles,

    You can attach an image (e.g. a .png image) to a post in a forum using the feature under the options tab. This is OK for small models.

    Larger models have to be uploaded to a section in the Library which only I can do (as the site admin)

    So if you have a small model, just embed it within a post. (See the Help file)
    If you want to upload a larger model, just send it to me and I will load it into the "open source models" section in the Library.

    Ken  
      

Page 1 of 1 (6 items)
© 2008-2020 The ORM Foundation: A UK not-for-profit organisation -------------- Terms of Service